MQTT, Instaneous Export - Question from the Glow Team



  • Well, I've a SMETS2 meter - no sign of export ever having worked - other than on the meter's own display. So I'm not sure that's quite correct.

  • edited February 2023

    My meter is an Honeywell AS302P:

    Using the local MQTT I do see a cumulative export figure but also expected the instantaneous export. well the current power to show positive for import and negative for export. 

    Is this possible without using a clamp? can the Glow MQTT show instantaneous export?

  • Hello @ianfretwell and @BNMBob - based on older comments in this thread, the instantaneous export question is possible with local MQTT, the challenge is meter type and firmware version.

    What are yours if you know them - and if you don't, drop us a line at support and we can check. Thank you.

  • Hello Jane, I am waiting for my supplier to update the firmware on my Honeywell AS302P as DDC other is not supported. (i also do not see the firmware anywhere).

    Once/IF done, Ill update this thread. Thank you

  • Hi @JaneatGlow, sorry about the slow response.

    No I don't think my loss of MQTT export meter total data coincided with DCC migration. I lost the export total in Apr 22, and pretty sure I was switched sometime later in the year.

  • Hello @JaneatGlow, the update of firmware on my Honeywell AS302P is done. looks like its now 09014009.

    No instantaneous Export.


  • Hi @JaneatGlow - my meter is a Secure Liberty 100. Its been migrated over to the DCC last year. Sorry but I don't know how to get its firmware version. If you can point me at some instructions I will post back what it is.



  • @bpeers - there is a screen on Bright in the Settings area that should give you the firmware. Are you getting your instantaneous export or not?

  • I am not seeing export being display on my display. These are my details.

    Aclara electricity meter with firmware version 00070806, Model SGM1412B.

  • My Meter is a EDMI ES-10B, firmware 0314B700. I'm not seeing energy export data. Energy import and power are both fine.

    As its a fresh set up, I'm wondering if in my case its due to lack of meter data consent for my export MPAN? I don't see any consent for that in the Bright App.

        "electricitymeter": {
            "timestamp": "2023-04-06T15:04:18Z",
            "energy": {
                "export": {
                    "cumulative": 0,
                    "units": "kWh"

  • Hi @JaneatGlow,

    My Display App firmware is 1.9.1 and the Zigbee firmware is 1.2.5.

    My MQTT data for export is shown below and has been like this since Nov '22.

    "export": {

    "cumulative": 0,

    "units": "kWh"


    Before the change in Nov '22 I was able to get the total export value from the meter. So something changed on the 17th Nov on my meter that then prevented the IHD from reading the Export cumulative value. I presume this was the date when the DCC pushed new firmware\ settings to my meters?



  • Hi Brodie / @bpeers,

    Could you drop an email to my attention to support@ - I can then see what firmware versions is on your electricity meter, not our device.

    FYI, the DCC only update the firmware on the Communications Hub - your energy supplier sends the meter firmware updates. On the other hand, ALL meter firmware versions have to be approved by the DCC.

    Complicated, isn't it!

    Thanks for your help,


  • Hello @JaneatGlow to add to your list, I have an elster (Honeywell?) AS300P (Smets1) on firmware 0401D8C9 and have no instantaneous Export on MQTT.



  • Thanks @philporter - we'll get the list consolidated and over to the DCC for discussion with meter manufacturers as apparently the guidance in the Smart Energy Code is that instantaneous export should be published.

  • Hi, unfortunately I'm unsure how to work out the firmware version but I've just had an Aclara SGM1411-B SMETS2 meter fitted and it only shows 0 on the IHD.

  • Hello @Freebo - thanks for your help - if you drop us an email to support@ we can look it up for you :)

  • I've recently set up my MQTT feed and, like others, my electricity export is showing as zero.

    My meter is EDMI ES-10A, firmware 0314B700.

  • Thought I'd just add this... after endless arguments with Octopus trying to get my Chameleon 3 IHD to display export power with the pylon ( as opposed to 0W and cost now £0.00) I found out that in order to achieve that, my smart meter needs to output export power as a negative number ( as opposed to 0000). My Aclara 1412B only sends 0 and so there's no way I can ever get my IHD to display export power. Aclara are aware but have no plans to change the firmware.... :(

  • Is there any update on this? My mqtt is still showing my export as zero.

    My meter is the old Secure SMETS 1 that Octopus installed that's had the firmware update (C0A10003)

  • Has any progress been made? on getting export data being passed from the smets 2 meters? my meter is an EDMI 10E2A100 firmware 0314B700 according to the Octopus HA Integration. I have been trying to get Octopus to get the DCC to enable the export to mqtt data flow but so far it just gets referred to the smart@octopus team and nothing comes back.

    It seems like a simple software switch that needs setting to 'on' to allow export data to flow in the same way as import does, if I have followed the various posts correctly. Is anyone with an EDMI meter getting export readings to an mqtt broker?

  • Itron EM425 UK2 here, installed via Octopus month ago. Everything works perfectly, including MQTT.

  • Good morning everyone, and a very Happy New Year to you all!

    Thank you for submitting your updates on what meters are working, and which aren't. I'll do a summary and send it over to DESNZ to ask for their support in getting suppliers to ensure that the Export is reporting cumulatively as expected.

    If you've any further points you'd like made - please let me know.

  • Jane,

    May I add my setup to the list of Smart Meter that are not reading export numbers?

    My meter is an EDMI ES-10b, firmware 314B700 (I think).

    The LCD screen in the EC-10b shows a number:

    But my MQTT stream does not:




  • Hi Jane - I'm following up on our email exchange [GIL-XIKRW-565] last week about export not being registered (as in permanently zero from at least June 2023) in the MQTT feed from our Glow IHD.

    The meter is an EDMI ES-10B. Its software version is 06A33757F and firmware 0314B700.

    Our supplier is Octopus.

    Good luck with following this matter up!


  • So I last posted in Feb '23 saying that mine had never worked (EDMI ES-10B) - I have only just realised today that it has started reporting export.

    Appears to have started at 2am on Dec 10th ' idea whether Eon-Next did something or whether you guys have enbaled something...

    Regardless of which - it's great to see it finally coming through (let's hope it lasts!)

  • Noting the comment from @ianfretwell I just checked the setup here and… still zero in - too bad!



  • @ianfretwell can you post your meter software and firmware versions?

  • edited February 5

    Hi - @gedger

    They appear to be:-

    Firmware:- 0314BA10

    Software:- 06A33757F

    So the firmware version does appear to be newer than the versions mentioned in earlier posts?

  • Hello Jane,

    I hope I'm not being too impatient? But as of today (5th Feb), I am not getting an Export reading. It is still reporting zero.

    CAD Ver. v1.9.1, ES-10b SMETS2, Octopus Energy.

    Regards, M.

Sign In or Register to comment.