No data on MQTT subscription


I have spent a good few hours on this today, followed up with Hildebrand support this morning and they've pointed me at this forum for support indicating that it's something my end.

My CAD is connected, the Bright app works, the API works (confirmed with — but my MQTT subscription simply does not show any messages being retrieved, either via TLS and non-TLS.

I've tried using

# python3

Connected and subscribed

<and nothing comes through>

I've tried mosquitto_sub

# mosquitto_sub -v -h -u <my email address> -P <my password> -t SMART/HILD/<my device id> -p 1883 --debug

Client mosq-0tzQBy2d72epfGJ5r8 sending CONNECT

Client mosq-0tzQBy2d72epfGJ5r8 received CONNACK (0)

Client mosq-0tzQBy2d72epfGJ5r8 sending SUBSCRIBE (Mid: 1, Topic: SMART/HILD/<my device id>, QoS: 0, Options: 0x00)

Client mosq-0tzQBy2d72epfGJ5r8 received SUBACK

Subscribed (mid: 1): 0

<and nothing comes through>

I have also tried:

 - changing my password from a super complex one to simple

 - confirmed this my device ID is correct

 - TLS and non TLS (with correct LetsEncrypt cert)

 - tried, substituting the variables as needed

 - tried, setting up a config.yaml based on config.yaml.example

Any thoughts?




Sign In or Register to comment.