Bright outage including APIs and MQTT



  • Bright App gone back down again this morning nit loading anything on my iPhone please tell the people again please Jane

  • That’s not working (Typo error)

  • Same issue for me too. MQTT stopped receiving data at 6:34 this morning. (thanks for the efforts in resolving this too, I'm only chiming in to mention the time in case that's helpful).

  • Thanks all for the updates - I don't think we've turned MQTT back on yet so that is expected.

    Bright app and data not loading this morning reports - it does load for me but very slowly. As you know - I'm not Tech Support but will find out why that is the case.

  • Just for information Jane I have had the Bright App not loading anything at all for over 30 minutes now…. all I see is a spinning wheel !! and it still us even now !

  • Still no MQTT here either.

  • @ghayne it’s mentioned several times by Jane that MQTT hasn’t been re-enabled yet.

  • Mine went down again this morning (7th Feb), just after 05:40 and is still off at 08:50


    Service has been restored. We are now checking data integrity and working through to confirm all environments are working as expected. If there are data gaps, they should be filled within the next 24 hours. Front end apps like Bright may be slow to load the data - we are working on the load balancer and service will improve. Please bear with us for the next 24 hours by which time we expect both performance and full data to be in place.

    We hope to restore MQTT shortly - we'll post here when it is.

  • Thanks for the updates Jane, I hope the boss is treating the team to lunch tomorrow!


    MQTT has been restored

  • Still trying to connect to the broker - guess it will take some time before it settles down.

  • I am trying to register via the bright app on iOS. I get to the check mpan step and it just spins. Is this service down currently?

  • @JaneatGlow - Looks like it has failed again (MQTT). Was up (for me) from about 11:40, but failed at approx 12:37.

  • Hi all - MQTT does have issues, we know and are dealing with them.

  • @JaneatGlow any update on MQTT please? Thank you.

  • Only recently started using HA and MQTT access. Spent yesterday and today thinking my setup must be wrong and trying all sorts to fix, then stumbled across this thread.

    DCC now working for me, but still no MQTT

    @JaneatGlow, thanks for all you’re doing to try and sort. Must have been an awful two days for you so far!

  • Bright App is really really flaky going between the menus and taking minutes to refresh between them ie settings>devices>gas history>electricity history> back to front screen display…takes ages I guess this will improve soon. Also no gas history for 2 days now since this outage but electric history is up to date (every 30 minutes)

    Appreciate this is taking a big effort to try to get the App back to its previous performance level

  • Thanks for the support everyone - I think it would be fair to say that we are all quite tired :)

    The team are working out why responses are slow - those of you who are techies will have their sympathy. Sorry for the ongoing issues - be reassured, no data is being lost.

    Brand new firewalls ordered (the one that blew up wasn't that old) and are due to arrive soon - then to get them installed.

    Have a good evening, Jane

  • @JaneatGlow

    Have a good evening yourself.

    What sort of time frame is the return of the MQTT feed expected?

  • The API has been on and off all day. Right now, it's unresponsive. curl is timing out after 30 seconds

  • Hi,

    Friday 3rd Feb Update….Bright App ver 2.0.13 (latest) on iPhone 13 max Pro running iOS 15.3 (latest)

    Backward step today… Now cannot load Bright App at all.. not even after 40 minutes of spinning wheel

    Just giving customer feedback here… as yesterday at least Bright Appi was working if you were prepared to wait long enough but today no not at all

    hope things get better soon

  • edited February 2022

    (as explained above) MQTT still not working for me !

    But I'm not seeing the app either - or the webpage version. Or to be more precise, both versions load OK but home page doesn't show anything.

  • Good morning all - we are obviously aware of the performance issues (to all intents and purposes the services are basically unusable due to the response times). The team are all working on the issue now - update will come when we have one. For now, don't even try using the APIs - do something more useful like make a tea or coffee :)

    Very sorry about the ongoing problem. We are down to performance - be reassured, no risk of data loss.

    @MichaelBarrett, you are a day ahead of the rest of us - in my world it is still Thursday!


    Performance should be closer to normal for APIs and therefore Bright.

    Remedial work continues - Clive will send an update later today with more technical background as I know many of you are very technical.

  • Thanks @JaneatGlow - so far so good on both the API and MQTT.

  • MQTT and API are working here.

  • Thanks Jane & Team and well done after a difficult few days. Your efforts are much appreciated. I think we tend to forget that this service is provided free of charge and the way you all go above and beyond when things go wrong is often overlooked.....


    For our customers with a CAD, Bright, our APIs and MQTT have been restored but response times may still be a bit slower than usual.

    For people who don't have our CAD and are using Bright or any libraries that rely on the 30 minute updates from the DCC, API or pseudo MQTT, they are not currently enabled and are returning HTTP 503. The overnight updates should be working as normal.

Sign In or Register to comment.