MQTT Woes

edited April 16 in API Info

Hi all,

I am trying to set up MQTT access for my Glow CAD and pull it into Home Assistant (HassOS, rather than HASSIO etc). Hildebrand have kindly switched on MQTT for me. I have followed the guides and thought I had the config correct, but any HA sensor I create using the data is simply displaying "unknown".

My Mosquitto config looks like this:


logins:

  username: XXXX

  password: XXXXX

anonymous: false

customize:

 active: true

 folder: mosquitto

certfile: server.crt

keyfile: server.key

require_certificate: true



and my glow.conf file (which is in \share\mosquitto\ as it is HassOS) looks like this:


connection glowmqtt

address glowmqtt.energyhive.com:8883

topic SMART/HILD/XXXXXX in 0

try_private false

notifications true

start_type automatic

remote_clientid unique cliend id

remote_username mybrightemail

remote_password brightpassword

keepalive_interval 300

cleansession true

bridge_cafile /etc/ssl/certs/ca-certificates.crt


In my mosquitto log I have: 


1618579742: Loading config file /share/mosquitto/glow.conf

1618579742: mosquitto version 1.6.3 starting

1618579742: Config loaded from /etc/mosquitto.conf.

1618579742: Loading plugin: /usr/share/mosquitto/auth-plug.so

1618579742: |-- *** auth-plug: startup

1618579742: ├── Username/password checking enabled.

1618579742: ├── TLS-PSK checking enabled.

1618579742: └── Extended authentication not enabled.

1618579742: Opening ipv4 listen socket on port 1883.

1618579742: Opening ipv6 listen socket on port 1883.

1618579742: Opening websockets listen socket on port 1884.

1618579742: Opening ipv4 listen socket on port 8883.

1618579742: Opening ipv6 listen socket on port 8883.

1618579742: Opening websockets listen socket on port 8884.

1618579742: Warning: Mosquitto should not be run as root/administrator.

1618579742: Connecting bridge glowmqtt (glowmqtt.energyhive.com:8883)


So the last line here looks like Mosquitto is connecting to glowmqtt. But what am I doing wrong? 


Any help appreciated!

Comments

  • This is a redacted version of what I've got in my Mosquitto bridge (in /etc/mosquitto/conf.d/glowmarkt.conf)

    connection glowmqtt
    address glowmqtt.energyhive.com:8883
    try_private false
    notifications true
    start_type automatic
    keepalive_interval 300
    cleansession true
    bridge_protocol_version mqttv311
    remote_username example@gmail.com
    remote_password myAPisecret
    topic SMART/HILD/AABBCCDDEEFF in 0
    bridge_capath /etc/ssl/certs
    local_clientid raspi_mosq
    remote_clientid raspi_glow
    

    That republishes every JSON message that comes in on SMART/HILD/AABBCCDDEEFF.

  • please test with a command line client like mosquito_sub

    I have just tested your feed and it is fine

    mosquitto_sub -d -v -h glowmqtt.energyhive.com -u $brightuser -P $brightpass -t "SMART/HILD/$yourmac"

    make sure you are using your correct bright credentials

Sign In or Register to comment.