MQTT Glow Cad Hildebrand Temperature Sensor

I recently received a temperature sensor to integrate with Home Assistant and I came across an issue with one of the fields having a numeric label and Home Assistant does not like it. I debugged the feed to Home Assistant and created two new MQTT sensor entries in the mqtt.yaml file on my system.

I am posting it below as it was not as easy to get working as the electricity and gas and it may help someone .

Message 0 received on glow/441793525A64/SENSOR/glowsensorth1/040D84282535 at 10:46:


   "glowsensorth1": {

       "040D84282535": {

           "timestamp": "2023-02-24T10:46:18Z",

           "temperature": {

               "value": 20.061,

               "units": "°C"


           "humidity": {

               "value": 58,

               "units": "%"


           "battery": {

               "value": 100,

               "units": "%"


           "rssi": {

               "value": -79,

               "units": "dBm"





Note the use of double and single quotes !!!!


  - name: "Kitchen Humidity"

     state_topic: "glow/441793525A64/SENSOR/glowsensorth1/040D84282535"

     state_class: measurement

     unit_of_measurement: "%"

     unique_id: a11674d8abfe42a885b0d80b0f2de03b

     value_template: "{{ value_json['glowsensorth1']['040D84282535']['humidity']['value'] }}"

  - name: "Kitchen Temperature"

     state_topic: "glow/441793525A64/SENSOR/glowsensorth1/040D84282535"

     state_class: measurement

     unit_of_measurement: "C"

     unique_id: 36743e3ac47f49808606cdb2685a4b91

     value_template: "{{ value_json['glowsensorth1']['040D84282535']['temperature']['value'] }}"


  • edited March 2023

    This is helpful thanks. I have used my glow DAC unit's unique ref in the yaml bits here 'glow/????????????/SENSOR' for the state_topic. The two new sensors have appeared, but I'm still not seeing any actual readings. I used your unique_id values above, so I am wondering where I would find the unique_id values for my unit, or are these values arbitrary?

    OK, I worked it out - my TH sensor had a different address than yours, which I'd spotted, but I'd entered incorrectly. All is working now, and as far as I can tell, the unique_id value is arbitrary.


  • If you're a bit finicky about these things and all your other sensors output °C as the temperature units, use:

    unit_of_measurement: "°C"

    in the temperature sensor definition

Sign In or Register to comment.