Home Assistant - Glow CAD

Hi, received my Glow Smart Meter Display & CAD last week and have been trying to set-up Home Assistant with it. I’ve followed various guides on this – robertalexa, megakid, speek-to-the-geek, etc – and no matter what I’ve done I still get the same issue that connection between the Mosquitto broker and the Hildebrand broker is closed before any data is transmitted. See today’s log:

2022-11-05 11:38:12: mosquitto version 2.0.11 starting
2022-11-05 11:38:12: Config loaded from /etc/mosquitto/mosquitto.conf.
2022-11-05 11:38:12: Loading plugin: /usr/share/mosquitto/go-auth.so
2022-11-05 11:38:12:  ├── Username/password checking enabled.
2022-11-05 11:38:12:  ├── TLS-PSK checking enabled.
2022-11-05 11:38:12:  └── Extended authentication not enabled.
2022-11-05 11:38:12: Opening ipv4 listen socket on port 1883.
2022-11-05 11:38:12: Opening ipv6 listen socket on port 1883.
2022-11-05 11:38:12: Opening websockets listen socket on port 1884.
2022-11-05 11:38:12: Connecting bridge (step 1) glowmqtt1 (glowmqtt.energyhive.com:8883)
2022-11-05 11:38:12: mosquitto version 2.0.11 running
2022-11-05 11:38:12: New connection from on port 1883.
2022-11-05 11:38:12: Client <unknown> closed its connection.
2022-11-05 11:38:12: Connecting bridge (step 2) glowmqtt1 (glowmqtt.energyhive.com:8883)
2022-11-05 11:38:12: Connection Refused: not authorised
2022-11-05 11:38:12: Client local.core-mosquitto.glowmqtt1 closed its connection.

I have added a Username and Password to Users in Home Assistant’s Settings -> People. The MQTT section of the CAD is set-up with my Bright App credentials, as I don’t have any others that I could put in those fields. The password is long at 20 characters but only contains upper case, lower names and numbers – no special characters. These credentials are also listed in my glow.conf file. The IP address is Home Assistant’s.

It is probably something simple I’ve missed but I feel I’m going round and round in circles. All help and comments appreciated.


  • Hi, I went through similar pain (Rasperry Pi, HA in a container) however I managed to do it. I would say:

    Restart Home Assistant, which seemed to sort a few issues out (Settings -> System, Restart link is in the top right corner)

    The MQTT section of the CAD has no username and password entered

    In my HA MQTT setting I have

    • Broker: ip address of my Home Assistant
    • Port: 1883
    • Username and password: I've kept blank for simplicity

    I hope that helps


  • Ah, just thought you might not be using local MQTT so some of that might be irrelevant 😊

  • Many thanks Mark for commenting.

    I've finally managed to get a connection to the Glow CAD! Well, my Energy dashnboard is being poplulated with electricity use. But it's a connection direct between Home Assistant and Glow's Cloud MQTT broker. This was achieved by configuring the MQTT Integration with Glow's address - glowmqtt.energyhive.com, port 1883, and my Bright app credentials - email address and password. Also, I entered my CAD device ID into megakids' Hildebrand Glow IHD MQTT integration rather than leave it as a '+'. I had uninstalled the MQTT broker add-on beforehand. Whether this was necessary or not, I don't know but wanted to avoid any possible conflicts between MQTT brokers.

    How much of what I did, not mentioned above, was necessary to get a connection is not clear. I will delete/uninstall everything back to a fresh HA install then start again. I will report back when it becomes clear!


  • Hi,

    I'm trying to get the data from the cloud MQTT into Mosquitto running in Home assistant. could you please share your conf file text please. I can reach the data using MQTT Explorer, but I can't seem to get it to work with Mosquitto it says disconnects with an protocol error. My conf text is:

    # Bridge to Smartmeter

    connection smart-meter-bridge

    address glowmqtt.energyhive.com:1883

    remote_username <My Username>

    remote_password <My Password>

    bridge_insecure true

    bridge_capath /etc/ssl/certs/

    topic SMART/HILD/<My MAC address for the cad stick> in 0

    bridge_protocol_version mqttv311


  • See my response on our other post. I think I needed to add the client_ids

Sign In or Register to comment.