Export meter total dropped to zero using MQTT

edited April 4 in API Info

Hi, has anybody seen issues with their export meter total value using MQTT?

Mine dropped to zero around 17:25 today. Checked the (SMETS1) meter locally & it still shows the correct export reading (just over 1,000kWh). Import meter total is still working correctly though using MQTT.

I am reading export from [702][00][01] and import from [702][00][00]

Here is the relevant part of the MQTT response;

{"elecMtr":

{"0702":

{"00":

{"07":"29DE0A8E",

"01":"000000000000",

"00":"0000019BA69E",

"14":"02",

"02":"00000000000A"}


Any thoughts?

Comments

  • I should also add, I have had this running in the same configuration for 6 months and it has worked perfectly, up until yesterday!

  • Did you get an answer from this?

    I bought the Glow CAD and it works wonderfully for 90% of everything. However, I bought it hoping that it would (a) tell me the current when exporting and (b) give me access to the export meter readings... however, on the MQTT feed, it does not show this.

    I am on SMETS1, however, been moved to DCC, so I am hoping it would be in there.

  • No, not yet unfortunately!

    Using MQTT, I can get instantaneous electric import/export (W), live import meter total (kWh), live gas meter total (kWh still even though I'm now billed in m3 but the numbers match my supplier).

    But ..... Export meter total has still not returned.

    As well as Glowmarkt I contacted my meter manufacturer to see if any firmware updates had been downloaded. Apparently not.

    Contacted my supplier (again) and eventually they replied, saying that they had been struggling to get my export meter total since the same day that I lost it😣. They are looking into it!

  • Ah ok. Many thanks for the update.

    My SMETS1 records the EXPORT values, however, I am on an old (but wonderfully lucrative) Feed-in-Tariff where I am paid for what I generate, not for what I export. So in theory, there is no need for EDF to need the EXPORT value from the meter... however, I want it!

    I'll ask EDF if they can export the EXPORT value to the DCC. If it works that way!

    Thanks, Neil.

  • I've just received my Glow CAD hoping I could measure both grid import and export and have the same problem. SMETS1 meter (connected to DCC) has the correct export reading on the meter but reads 0 over MQTT. The import is fine. I'm about to switch to octopus energy at the end of the month though so with a little luck it might appear (or I can find the export reading from somewhere else...)

    Interested to find out if this is something that's configured in the smart meter, at the energy provider, at glowmarkt or at DCC!

  • "Interested to find out if this is something that's configured in the smart meter, at the energy provider, at glowmarkt or at DCC!" - this is what I am thinking too. I don't want to prod EDF too hard as I am on a "deemed" FIT and don't want that to change (obviously).

    But I understand that Glow cannot really offer support on the MQTT stuff, so sort of stuck at the minute.

Sign In or Register to comment.