MQTT, not receiving data

Hey folks,

Another person here who's not receiving MQTT data after having it enabled and I'm hoping someone here can point me in the right direction. I assume I'm doing something wrong.

I've tried two different versions of mosquitto_sub. Version 1.5.7 (old raspberry Pi) and 2.0.11 and get slightly different responses depending on version and protocol version, but no data from either:

# mosquitto_sub version 1.5.7
mosquitto_sub --cafile /etc/ssl/certs/ca-certificates.crt -h glowmqtt.energyhive.com -u <bright_email_addres> -P <bright_password> -t SMART/HILD/A8032AD62560 -p 8883 -d -v
Client mosqsub|3273-hass sending CONNECT
Client mosqsub|3273-hass received CONNACK (0)
Client mosqsub|3273-hass sending SUBSCRIBE (Mid: 1, Topic: SMART/HILD/A8032AD62560, QoS: 0)
Client mosqsub|3273-hass received SUBACK
Subscribed (mid: 1): 128
Client mosqsub|3273-hass sending PINGREQ
Client mosqsub|3273-hass received PINGRESP

And

# mosquitto_sub version 2.0.11
mosquitto_sub --cafile /etc/ssl/ca-bundle.pem -h glowmqtt.energyhive.com -u <bright_email_addres> -P <bright_password> -t SMART/HILD/A8032AD62560 -p 8883 -d -v
Client (null) sending CONNECT
Client (null) received CONNACK (0)
Client (null) sending SUBSCRIBE (Mid: 1, Topic: SMART/HILD/A8032AD62560, QoS: 0, Options: 0x00)
Client (null) received SUBACK
Subscribed (mid: 1): 128
Client (null) sending DISCONNECT
All subscription requests were denied.


# mosquitto_sub version 2.0.11 MQTT v3.1
mosquitto_sub --cafile /etc/ssl/ca-bundle.pem -h glowmqtt.energyhive.com -u <bright_email_addres> -P <bright_password> -t SMART/HILD/A8032AD62560 -p 8883 -d -v -V mqttv31
Client mosq-wUn56AcfRxzegJekxe sending CONNECT
Client mosq-wUn56AcfRxzegJekxe received CONNACK (0)
Client mosq-wUn56AcfRxzegJekxe sending SUBSCRIBE (Mid: 1, Topic: SMART/HILD/A8032AD62560, QoS: 0, Options: 0x00)
Client mosq-wUn56AcfRxzegJekxe received SUBACK
Subscribed (mid: 1): 0
Client mosq-wUn56AcfRxzegJekxe sending PINGREQ
Client mosq-wUn56AcfRxzegJekxe received PINGRESP

Any thoughts on what I've missed or need to change?

Comments

  • edited October 6

     mosquitto_sub -p 8883 --capath /etc/ssl/certs -h glowmqtt.energyhive.com -u "example@gmail.com" -P superSecretPassword -t "SMART/HILD/DEADBEEFCAFE" 

    I use --capath rather than --cafile as that gets mosquitto_sub to search for the certificates it needs.

  • Thanks for the suggestion Dougie. That is something I hadn't tried, but sadly doesn't change the behaviour. If that setting was incorrect I wouldn't expect the client to be able to connect at all due to not being able to established a trusted TLS connection.

  • I have had this happen before and hard rebooted the IHD and once it was back up, it started working. Probably a daft questions, but have you checked that you can get data via the API and Bright App ?

  • Send an email to support@glowmarkt.com with your IHD serial number to get Clive and/or Jane to take a look at this for you.

  • Hey DMoore, great suggestions. I was meant to try the API before trying here so thanks for the reminder. Both the API (using pyglowmarkt) and the Bright app seem to work fine from what I can see. Also tried the hard reboot as you suggested and still nothing so far.


    I'll drop support a quick email as Dougie suggested.


    Thanks again people.

  • @TikiGod - How did you get on with your email to support, is MQTT working for you now ?

  • DMoore, I'm still in communication with support right now. I'm aiming to update this thread with findings once I get it working.

  • This is all working now. It seems my use of tagged email address was causing the problem. So for anyone else that may read this in the future, don't use a '+' in your username/email address.

    Jon

Sign In or Register to comment.