SMETS1 CAD Stick Crashing

I have had an issue since Sunday where the SMETS1 CAD Stick seems to lock up and crash nearly every hour and a physical unplug seems to resolve it temporarily.

I was wondering if there has been a recent firmware release for these devices that is causing the issue or may I just be unlucky and have a potential hardware fault with it.


  • edited July 2022

    I am see something very similar.

    Since Saturday afternoon my stick has been dropping it’s wifi (WIFI light on stick turns red) connection for around 15-20 minutes almost every hour.

    No idea if this is a firmware issue or hardware fault.

  • I'm so happy I found this post as I have been having the same issue - although with me it seems to just disconnect (red light on the stick) for a few seconds and then connect again - however my minute graph is a spotty mess.

    I opened a ticket about it yesterday but thought it was an issue with my WiFi but if you are all experiencing similar issues then it must be something else.

    As part of the e-mail exchange I had with Jane yesterday she said the firmware hasn't been changed so it's all very odd.

    Mine had been working flawlessly for months then on Saturday 23rd July at 14:55 it turned into a patchy mess and has been like that since.

    I tried multiple things including setting it up on its own network, changing WiFi channels and nothing seemed to work.

    Out of interest what ISP are you with? I'm with Virgin. I'm wondering if the red light signifies actually being dropped from the WiFi or if it can't contact the Glow server. If some of the packets are being dropped on the way / being blocked by something could this be the cause?

  • Im with ZEN internet on FTTC, but the connection is very stable as i'm only a few yards from the cabinet and has dropped the VDSL once in 12 months according to my Nagios Monitoring. The wifi setup is the TPLink Omada Access Point system and again that is all running fine as I've done some checks and alot of other ESP8266 'homebrew' devices around the house are still connected when the drop happens.

    The behaviour I have found is that it generally locks up (wifi light goes red) somewhere between 10-15mins past the hour each hour, however a few times it happens in the xx:30 - xx:40 time range also. The stick sometimes sorts itself out after 20mins, but sometimes it doesn't, so a power cycle is required.

  • Just had an afterthought. The CAD stick is on my main 'noisy' VLAN and all my 'esp' style devices have their own segregated VLAN which is less noisy as its a known issue that ESP processors get overwhelmed and crash when they see lots of broadcast messages. I'll switch it over and see if that makes any difference.

  • I’m with trooli fttp, which i moved to just under a month a go. So initially I thought that this may have been the issue.

    But I have just noticed the time and date which you say yours stopped working. If I check my graphs the time and date are almost exactly the same. i.e. my issue started at Saturday 23rd July at 14:52

    Also, now that I think about it when the the wifi light goes red, I don’t think the stick disconnects from the router. I am waiting for the next time this happens, so I can double check.

  • I only noticed it at around 11am on Sunday however I have checked the graph in Home Assistant and it started on Saturday with the first dropout at 3:26:48PM lasting 10 minutes with it sorting itself automatically.

    The isolated VLAN makes no difference from what I have found and 'red light' still happens. I have also found from looking at my Wireless controller that it doesn't drop the connection when the light goes red. However the device becomes un-pingable.

  • Hi all - as you know we don't have time to check the forums so thank you to @IanW for flagging this thread to me.

    We've had two of you report the issue to support - and several thousand of the units in the field so it definitely isn't affecting everyone.

    What I am wondering is whether one of the other commonalities is that you are also taking the MQTT over the cloud? I've absolutely no idea why that would affect things (for those who don't know, I am not technical) - but just want to help with diagnostics for the Tech team.

    For the other 'common' factor - did this start Saturday afternoon?

    I can confirm that we've not made a firmware update to the GlowStick - and haven't done one for a few years now.

    Thanks for your help with getting to the common factors.


  • I am setup for MQTT and have tested that it works when I was first sent the details but not currently using the data locally.

  • I am only using GlowStick with the Bright App. and as I mentioned in earlier post this started on Saturday afternoon.

  • I happened to catch it when it was showing red and as far as I can tell it was still connected to my WiFi network but wasn't responding to pings.

    What Smart Meter have the others experience this issue got?

    I'm have a Liberty 100 E1S0B1 and I'm with Eon Next.

  • edited July 2022

    My device is showing as seen by the app, but as reporting no data since a bit after 4am this morning according to my ha charts. I can’t restart it since it is in a remote cottage.

    EDIT: Bright app says it stopped at 4:22am

  • I've got a Liberty 100 E1S0B1 also on SMETS1.

    I've recently transfered to Octopus from OVO and told Octopus to enable export for my recent solar panel install and thats when the trouble started..... I'm not fully sure that it is a coincidence that switching started the problem as Jane at Glowmarkt doesn't think it makes any odds as they are still providing data albeit when the stick is connected. However after a fortnight of being on service with Octopus, they still can't provide any data in my online octopus account as to my usage and im treated as a customer who has the antique meters that require me to give meter readings which is really bizarre as I just give them the consumption readings from Glowmarkt. If glowmarkt can get data from the meters then meters have definately had the DCC firmware upgrade.

    I do think the DCC have some settings they have pushed down the SMETS1 (courtesy of of Octopus) when it comes to how the meters behave on the HAN and that is what is causing the CAD stick to go do-lally..... Well thats my conspiracy theory on it.

    I'm half tempted to cut my losses with the SMETS1 meters as they are pain the **** when switching suppliers as I had some similar fun and games 12 months ago when switching last year from Utility Warehouse to OVO and tell Octopus to swap them out for SMETS2 meters and get another CAD from GlowMarkt. @Jane I would be interested in what the Glowmarkt upgrade path is?

    Meanwhile. Back to the diagnostics..... When the red light comes on, the wifi is still connected, but it becomes un-pingable. My next test is to see if steam driven (Secure PIPIT) in home display goes haywire at the same time. I will report back...

    May be worth anyone with issues reporting back when they switched to their current supplier or have enabled anything like export or a tariff change?

  • My meter is an ELSTER AS300P (SMETS1)

    Current supplier is Shell Energy who I have been with for last 18 months.

  • Hi all - hope you enjoyed your weekend.

    Tech Support tell me they've made a tweak this morning - that seems to have worked for one of you - has it for everyone?

  • Mine seems to be working normally again, there have been no gaps in data since approx. 9:50 this morning.

    Thanks for getting this resolved.

  • You are welcome - thanks for confirming all good.

  • Yes, mine is looking good too.

    Thanks for getting this looked into.

  • Mine still isn't reporting. It shows my meter device as last being seen at 12:30:00 am today. That is a change from the 4:22 am it said yesterday. Unfortunately I can't restart it until end of the month, so hoping it will recover by itself.

  • Seems to be going now

  • Sounds as though the fix has done the trick for everyone.

    Next time, please do tell me via support first - thank you.

  • It seems be stable again now. Was there a root cause that you are able to divulge to us?

  • I'll leave answering your question to IT Ops - your question is above my pay grade ;)

  • Has anyone seen the problem start appearing again (as of 19th September 2022)? Mine has started to do the same behaviour. I've emailed Jane at Support so will report back.

  • a part from 2 gaps in the data between 06:30-07:00 this morning mine seems to be working fine.

Sign In or Register to comment.